Page 1 of 1

Extruder fail

Posted: Mon May 08, 2017 7:39 pm
by AtomicSky
I've been using S3D for about 2 months with my Monoprice Mini Select without a problem. Last week my Prusa i3 Mk2 arrived. I put it to work right away printing around the clock for about 5 days without an issue. Then I had a strange problem with one part where the extruder stopped after about the 10% point. After that the printer was just going through the motions.

At first I thought it was a nozzle clog. So I cleaned it up and tried the part again. And, again, at about the 10% point the extruder stopped. I then tried a different but similar part to print. And, again, at about the 10% point the extruder stopped. I then selected a completely different part from a different vendor. It printed just fine. I then when back and selected a part that was also similar but different than the two problematic parts. And, yes, the extruder stopped. I went back to my MP Mini to print the first two problem parts. And they printed without a problem. At this point I used Cura 2.4 to slice the problem parts for the Prusa. And viola! They printed.

So, what the heck is going on? I don't tweak my slicing setting. About the only thing I ever change is the layer height and infill. And I doubt it is the STL vendor. They also print their models on an i3.

Here is a really terrible photo of the failed parts. As you can see the extruder stopped just after finishing the floor board areas.

The curved parts are balconies from an observatory model by Printable Scenery. And the big rectangular-ish part is a Merchant building also by PS. ... servatory/

Re: Extruder fail

Posted: Tue May 09, 2017 7:38 am
by brian442

Re: Extruder fail

Posted: Tue May 09, 2017 8:58 am
by wirlybird
Has the firmware on the Prusa been updated to the latest?
Have you tried using the Prusa version of Slic3r?
Are you printing from SD card?

Re: Extruder fail

Posted: Tue May 09, 2017 2:43 pm
by AtomicSky
Yes, Prusa is latest firmware. And I am printing from SD card. And I have looked at the support page with the bit about extruder stopping. But I really don't think it's mechanical/electrical. I was able to successfully print all the failed parts with Cura 2.4. I think there is something wacky in the gcode. I'm not a gcode hacker, so wouldn't know what to look for. I tried printing one of the smaller failed parts again using S3D after successfully printing with Cura 2.4. And again the part failed. So I'm pretty darn sure it has something to do with the gcode created by S3D.

Re: Extruder fail

Posted: Wed May 10, 2017 1:07 pm
by Derrick
Your nozzle is clogged. Get a new one. Even if it's a new nozzle - it's a bad one. Get a new one.

When degradate builds up in a nozzle, the orifice size is much smaller. Or if there was a machining defect. Most extruders can still get enough push on the filament to squeeze material through smaller holes at similar volumes; however, any blip in this, like a temp fluctuation, a contaminant in the filament, or printing on the edge of too fast, can cause the filament to bind up and the extruder gear will start grinding into the filament.

If towards the end of the print file (open in Notepad++ or similar) you still see E values on all of the G1 moves, then the printer is attempting to push the filament through. Additionally, if the filament is ground where the extruder is, then the printer was trying to push material through. It's not the file.

Re: Extruder fail

Posted: Wed May 10, 2017 4:07 pm
by wirlybird
First thing I think of is the SD card is being removed to quick before S3D finishes writing to it.

Also look in S3D to make sure you don't have multiple processes or something else that limits the layers.