User avatar
AK_Eric
Posts: 103
Joined: Thu Dec 25, 2014 4:48 pm
Location: Belmont, CA
Contact: Website

[SOLVED] Coasting Distance: Has no effect?

Sat Aug 12, 2017 4:24 pm

I've been using S3D for a number of years now, pretty familiar with it, but I'd never used the 'Coasting Distance' option : Have a bigger nozzle, getting some blobbing a the end of the extrusion that wipe isn't addressing, so I figured I'd try this.

And try I have: Probably 5 different test-cylinders broken into 5 processes each with difference coast settings. And none of them look any different. Tested this in both S3D 3.0 & 4.0. Save factory file, closed/reopend the software, turned the checkbox on\off \ resave etc. It just does, nothing.

Here's a pic of my end results. The nozzle is traveling screen left -> right, so the left side of the zipper coasting should address. I also turn off my fan briefly between sections so they're easier to tell apart. In this case, all the same:
no_coast.jpg
Here's a pic of the gcode: Clearly there should be some gaps forming, since I put some really big values in there (2mm for example):
coast_gcode_preview.JPG
coast_gcode_preview.JPG (18.38 KiB) Viewed 3647 times
I did another test with even *bigger* values, still no effect.

Here's my factory file for inspection:
no_coast.factory
(16.59 KiB) Downloaded 349 times
I'm using a custom build core-xy printer with RepRap Firmware runnnig on RADDS, .6mm volcano nozzle & bondtechBMG extruder.

Any thoughts as to why this would be happening? I'll attach my gcode in the next post.
Bots:
Makerbot Replicator 2x / Sailfish on Mightyboard
Custom C-Bot / RepRap Firmware on RADDS
Custom Tevo Little Monster / RepRap Firmware on Duet

User avatar
AK_Eric
Posts: 103
Joined: Thu Dec 25, 2014 4:48 pm
Location: Belmont, CA
Contact: Website

Re: Coasting Distance: Has no effect?

Sat Aug 12, 2017 4:25 pm

And here's the gcode:
no_coast.gcode
(136.22 KiB) Downloaded 512 times
Bots:
Makerbot Replicator 2x / Sailfish on Mightyboard
Custom C-Bot / RepRap Firmware on RADDS
Custom Tevo Little Monster / RepRap Firmware on Duet

User avatar
AK_Eric
Posts: 103
Joined: Thu Dec 25, 2014 4:48 pm
Location: Belmont, CA
Contact: Website

Re: Coasting Distance: Has no effect?

Tue Aug 15, 2017 12:01 am

Contacted S3D Support: With really big vals, like 5mm and greater, I'm starting to see some effect. Guess I didn't aim big enough to start.
Bots:
Makerbot Replicator 2x / Sailfish on Mightyboard
Custom C-Bot / RepRap Firmware on RADDS
Custom Tevo Little Monster / RepRap Firmware on Duet

nkuck
Posts: 30
Joined: Mon May 23, 2016 2:32 pm

Re: [SOLVED] Coasting Distance: Has no effect?

Fri Jul 10, 2020 12:55 pm

Have you been successful in really getting this resolved? I’m up to a coasting value of 16, still with no effects. :x

airscapes
Posts: 334
Joined: Tue Mar 06, 2018 10:35 am
Location: Philadelphia PA Area

Re: [SOLVED] Coasting Distance: Has no effect?

Fri Jul 10, 2020 3:29 pm

Just curious what artifact coasting is supposed to fix, never used it.. Oh NM layer change..

User avatar
dkightley
Posts: 2253
Joined: Tue Mar 10, 2015 4:09 pm

Re: [SOLVED] Coasting Distance: Has no effect?

Fri Jul 10, 2020 8:11 pm

Too late at night for me to be bothered repeating what can be found elsewhere!

Read these:
viewtopic.php?f=8&t=1980

https://www.simplify3d.com/support/prin ... -and-zits/


And btw.......coasting DOES work. You just need to know what it does first to be able to recognise what it's effect is!
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

Return to “Troubleshooting and Bug Reports”