User avatar
dkightley
Posts: 2096
Joined: Tue Mar 10, 2015 4:09 pm

Re: v4 hangs when slicing a model

Tue Sep 05, 2017 5:51 pm

Broart

The shape file you have used seems to have some errors in it that S3D is not able to handle when the overlap is at 10% ( and even 20%). I've run the shape file through Microsoft's repair service and re-tested....and it slices like a breeze!

Repaired file attached
Attachments
Andy_servo_bracket_b_repaired(2).stl
(1.61 MiB) Downloaded 141 times
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

nerys
Posts: 138
Joined: Tue Mar 29, 2016 8:47 pm

Re: v4 hangs when slicing a model

Tue Sep 05, 2017 6:48 pm

hey. i never thought of trying that. maybe there is something hinky in my file. ....

Iwill run it through netfabb and see what happens. worse it can do is nothing ehh :-)

Broart
Posts: 2
Joined: Sun Sep 03, 2017 5:56 pm

Re: v4 hangs when slicing a model

Fri Sep 08, 2017 12:35 pm

If you set "Allowed perimeter overlap" to 10%, slicing will fail above 3mm, as soon as it hits any hole it seems. Mine was default at 10%, so I believed every one else was too. But it works at 50%

nerys
Posts: 138
Joined: Tue Mar 29, 2016 8:47 pm

Re: v4 hangs when slicing a model

Sat Sep 09, 2017 1:33 pm

I will try that tonight and see what happens. Thank you.

littlecat
Posts: 8
Joined: Wed Feb 18, 2015 1:25 am

Re: v4 hangs when slicing a model

Sat Oct 07, 2017 6:01 pm

Hey, I've been really frustrated with this problem lately as well. Unfortunately I can't post my factory file right now due to IP disclosure reasons, but the basic problem is that slicing with single extrusion fill selected on larger models often results in the slicer hanging indefinitely with the message "calculating infill" for no apparent reason. I've noticed that sometimes very small shifts in geometry - like offsetting the model placement by a millimeter or two - can cause the issue to appear or disappear, with maddening inconsistency. I hope this is a priority for the dev team right now; I'd really like to see it fixed in the next release... thanks guys for making a generally excellent product; I hope we can get this bug cleared up as soon as possible.

kfonda
Posts: 2
Joined: Fri Sep 08, 2017 5:39 am

Re: v4 hangs when slicing a model

Thu Oct 19, 2017 7:38 pm

Just in case it helps track down the problem I thought I would post my experience here. I had the same problem with a file and solved it by dropping the 'Outline/Perimeter Shells' from 5 to 4. The 'Internal Thin Wall Type' was set to 'Allow single extrusion fill' at the time. Any setting above 4 shells would cause the failure.

FlyingDutch
Posts: 16
Joined: Wed Oct 04, 2017 11:45 am

Re: v4 hangs when slicing a model

Tue Oct 24, 2017 5:45 am

There's simply a bug in S3D where it comes to thin wall extrusions. A bug which was introduced in the latest version, the previous version does not have this issue. So it's a new bug which would need to be fixed.

I would dare to wage a sizeable bet on that your file will slice fine in S3D 3.11. Haven't tried it tho, but can guess the outcome.

See my thread, which turns out to be exactly the same bug:
https://forum.simplify3d.com/viewtopic.php?f=9&t=8558

FlyingDutch
Posts: 16
Joined: Wed Oct 04, 2017 11:45 am

Re: v4 hangs when slicing a model

Tue Oct 24, 2017 6:01 am

For the heck of it.. I have both 3.11 and 4.00 installed, if I right click a file I can choose to open it with 3.11 or 4.0.

And, sure enough, 3.11 has no issues whatsoever slicing your file:

Image

The issue is not your file or settings. The issue is the slicer.

LegacyGT
Posts: 1
Joined: Thu Nov 30, 2017 7:18 pm

Re: v4 hangs when slicing a model

Thu Nov 30, 2017 7:30 pm

@FlyingDutch, I'm on the fence about buying Simplify3D. I have a few of the 3DLabPrint planes and want to be able to print individual parts for crash repairs. CURA and MatterControl aren't giving me the quality prints I want. I saw your previous posts about "4.0 crashes on this factory; 3.11 does NOT" and was wondering if you'd had any luck solving the crashing issue?

Patrick

wirlybird
Posts: 1230
Joined: Sun Jul 17, 2016 1:32 pm

Re: v4 hangs when slicing a model

Sat Dec 09, 2017 9:57 pm

For anyone who is interested. I was having the freeze at "calculating Infill" in Ver. 4. If "internal Thin Wall Type" is set to "Allow Single Extrusion Fill" it freezes. If set to "Allow Gap Fill" it will slice.
Hope that might help someone.

Return to “Troubleshooting and Bug Reports”