Festus440
Posts: 77
Joined: Wed Aug 07, 2013 8:38 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 7:33 am

Yup. 3Drasle was right all along.
Trying it now but by looking at the gcode I can see that the mode has changed to absolute and the negative extrusion values are now gone.
The check box is "Allow zeroing of extrusion distances (i.e. G92 E0).

I was thrown off by the fact that Kisslicer still used that command.
Last edited by Festus440 on Tue Apr 22, 2014 3:14 pm, edited 1 time in total.

Lonestar9192
Posts: 20
Joined: Tue Apr 08, 2014 9:08 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 7:40 am

When you see a perfect print you'll thank me lol. I gotta thank everyone for testing and giving clues.

Festus440
Posts: 77
Joined: Wed Aug 07, 2013 8:38 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 7:46 am

Yup. The print isn't finished but I can already see that it's working now.
Thanks to all.

User avatar
3Drasle
Posts: 83
Joined: Thu Jan 30, 2014 6:29 am

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 8:23 am

3Drasle wrote:I had a similar problem long time ago. I think it was caused by a G92 E0 during the print.
My Makerbot hardware and Sailfish only want that at start, else it would skew the print.

Edit: You could try unchecking "allow zeroing of extrusion distances" under the G-code tap...


/Michael
Wow, took me 5 days to convince you 8-)

Will enjoy the sun for a while ,and then run back to my hole in the ground :lol:
Glad it worked out for you in the end.

/Michael
/Michael, Denmark

Binni1969
Posts: 15
Joined: Tue Apr 01, 2014 12:46 am

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 8:49 am

Hi,

wow, a big THANK YOU to all of you.
Will give it a try this evening!

Festus440
Posts: 77
Joined: Wed Aug 07, 2013 8:38 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 9:41 am

Michael,
As I said earlier, you were right. Classic case of bad timing. I missed your earlier post but by the time you mentioned it again I had seen that Kisslicer does use G92 E0.

The G92 E0 command itself is not the problem. Its relative vs. absolute mode. (I had asked earlier if there was a way in S3D to change that.)
So now that I know more I can see what is happening. In S3D with that check box off, gcode goes to absolute mode and the size of the extrusion grows bigger and bigger until the end of the file. Thousands of millimeters by the end of my part.

What Kisslicer and Slic3r do is continually reset the extruder and start over (still in absolute mode however) after some loops are complete. That's whey their gcode is still full of the G92 E0 commands.

So the description on that checkbox in S3D could be a little clearer.
Last edited by Festus440 on Tue Apr 22, 2014 2:55 pm, edited 1 time in total.

mfc
Posts: 9
Joined: Tue Apr 15, 2014 2:06 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 10:23 am

I will test if you still need people!

Binni1969
Posts: 15
Joined: Tue Apr 01, 2014 12:46 am

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 2:51 pm

OK,
first test has been a success!

Lonestar9192
Posts: 20
Joined: Tue Apr 08, 2014 9:08 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 2:52 pm

Awesome, you don't know how happy I was when I got a good print

Festus440
Posts: 77
Joined: Wed Aug 07, 2013 8:38 pm

Re: Major bug, x-axis leaning to the right (positive)

Tue Apr 22, 2014 9:23 pm

Unless I'm reading this wrong (certainly possible in my case), there really is a bug in S3D.
The bug is in the G-Code panel.
The checkbox we are turning off should have nothing to do with changing the extrusion mode from relative to absolute. It should only change if G92 E0 commands are used during the print. (And as shown before both Kisslicer and Slic3r use those with no problem.

However, the checkbox above that IS the one that should control absolute mode (and the default as shown IS set for absolute, but it apparently isn't working correctly. (or probably more correctly, the G92 E0 checkbox is putting the g-code back to relative mode in error.)
absolute  bug.jpg
absolute bug.jpg (36.28 KiB) Viewed 5225 times
The default options as shown should produce g-code just like Kisslicer (absolute extrusion mode & resetting the extruder position as it goes through the file). But of course we now know it doesn't.

I looked at all the combinations of those two checkboxes and I didn't find any combination that created code in the same way as Kisslicer and Slic3r (although like I said, the combination shown above should do that).
So for now, just turning off the G92 E0 checkbox is the fix.

Also, checking both of those boxes seem to be a very weird (well at least to me) mode where there is both negative and positive retractions:

G1 X25.651 Y19.73 E0.1992
G1 E-0.5 F1800 <------
G0 X23.08 Y18.397 F4800
G1 E0.5 F1800 <------
G1 X23.76 Y18.14 E0.0242 F2880

I may try that but I've already wasted a lot of plastic on this thing :roll:

Return to “Troubleshooting and Bug Reports”