curious aardvark
Posts: 51
Joined: Wed Oct 01, 2014 10:02 am

observations of 4.0 versus 3.1

Sat Sep 16, 2017 9:53 am

Done a fair few prints with 4.0 now and while I can't honestly say there's any quality or speed difference over 3.1 - there are a couple of annoying changes.
The only difference I've noticed is that the speed settings now have their own tab.

When printing via usb, 3.1 would show me a 'live' animation in real time of the print in progress.
4,0 does not. Just shows the static printhead and occasionally updates the model - but I no longer get a live animation of what's being printed.

Also if you use the 'play/pause' animation controls at the bottom of the screen for a virtual print preview - again I no longer get an active animation of printhead movement. On the slowest settings I now just get a pretty fast layer by layer animation, and on the faster settings it just builds it - again layer by layer at a ridiculous speed.

Is there some method of changing this back to how it was in 3.1 ?

It's actually really useful to be able to see the toolhead movements - in real time - rather than just a whole layer in one go.

arhi
Posts: 451
Joined: Thu Oct 06, 2016 5:13 pm

Re: observations of 4.0 versus 3.1

Sat Sep 16, 2017 12:54 pm

I don't use s3d to print files (octoprint is imo the way to go with telegram plugin and many other goodies) so can't help there but the play you are mentioning on the g-code view page (simulation) will work as you want it (line by line) if you change the "control options" section of the screen, "preview by" dropdown to "Line" instead of layer. This way you get animation of toolhead actual movement.
Capture.JPG
maybe the same thing will help with your actual printing of files
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

gearsawe
Posts: 150
Joined: Sun Sep 10, 2017 11:06 pm

Re: observations of 4.0 versus 3.1

Sat Sep 16, 2017 4:49 pm

As far as the live update, since they added more option to preview things there are now more settings to adjust to updates.
first
check live preview tracking
change update time to "0.1"
and change preview by to "line"
and it will update every 0.1seconds by lines. default is but layer and every 5 seconds. maybe the fast update is to fast for some computers and printers/computers? Now if there was a way to change the defaults?
LiveUpdate.JPG

brian442
Posts: 1243
Joined: Mon Nov 28, 2016 5:35 am

Re: observations of 4.0 versus 3.1

Sun Sep 17, 2017 8:38 am

curious aardvark wrote:When printing via usb, 3.1 would show me a 'live' animation in real time of the print in progress. 4.0 does not. Just shows the static printhead and occasionally updates the model - but I no longer get a live animation of what's being printed.
I'm running a print right now and this works fine for me. I'm guessing you have the preview set to layer mode instead of line mode. That means that it will only show a complete layer, so you would only see an update after each entire layer is printed.
curious aardvark wrote:The only difference I've noticed is that the speed settings now have their own tab.
There's a lot more stuff than just speeds. If you haven't already, you might want to read this page:
https://www.simplify3d.com/software/rel ... ion-4-0-0/

curious aardvark
Posts: 51
Joined: Wed Oct 01, 2014 10:02 am

Re: observations of 4.0 versus 3.1

Mon Sep 18, 2017 3:18 pm

Ah ha !

Thanks, that works :-)

Sure there are other differences, just not done any multi process prints yet.

Return to “Troubleshooting and Bug Reports”