Posts: 220
Joined: Sun Feb 02, 2014 4:40 pm

The new version quirk with printing

Tue Apr 15, 2014 7:34 am

The "Begin printing over USB" just gives me "Unable to export to selected location" on 2 Machines for me.
What selected location??

I can't find anything in the docs and nothing in the settings.

But i can print it anyway, because it appears in the machine Control G-Code library.

Otherwise it is a great update.

Posts: 1435
Joined: Sun Feb 16, 2014 10:52 am

Re: The new version quirk with printing

Sat Apr 19, 2014 8:36 am

Try running as administrator. Does that make a difference? That would narrow it down to permissions issues

Posts: 4
Joined: Thu Apr 24, 2014 3:42 am

Re: The new version quirk with printing

Thu Apr 24, 2014 3:44 am

Same problem here. I run it under Mac OS X 10.9.2

Posts: 1
Joined: Wed Jan 06, 2016 10:50 pm

Re: The new version quirk with printing

Wed Jan 06, 2016 10:58 pm

Since this was the post albeit really old that came up when I did a google search for my problem "Unable to export to selected location" I figured I'd put my fix here so when I forget in a week or 2 I will get the answer! Also help anyone else running into this problem!

If you are running S3D as a user, but for some other reason run it as root, some files temp in your user directory can get written as root with root only permisions. Ever after you won't be able to print via usb as a user anymore. To fix this you must update the owner ship of the temp files back to the user.

to do so in linux I ran the following command:
cd .local/share
sudo chown -R $USER Simplify3D

you can also do group too, but I don't think that matters a lot.
sudo chgrp -R users Simplify3D

Thanks and good luck, Josh

Posts: 2005
Joined: Wed Aug 05, 2015 7:23 am

Re: The new version quirk with printing

Thu Jan 07, 2016 6:28 am

They include an AddUserPermissions script that does a lot of this too. It has a command to edit the permissions on that file already. It's used anytime you need to make sure a non-root user has access to the software.

Personally, I just run the software as root anyways since that's much easier and I don't have to mess with all the permission settings for serial ports, directories, etc.

Return to “Troubleshooting and Bug Reports”