UABMaddog
Posts: 2
Joined: Wed Oct 25, 2017 5:16 pm

Printrbot G2 board upgraded Simple Metal

Fri Nov 17, 2017 9:20 pm

I have upgraded my Simple Metal with the extended X & Z, heated bed, 4 start lead screw, Ubis 13S hot end, Gear Head Extruder v2 and the big one, the G2 board.

The board doesn't store the upgrade codes, so I have to put them in the start script. I got everything working with Cura 3.04 connected via USB. Got my Octopi talking to the board and running the Cura gcode. The S3D gcode would hang the printer.....looking at the gcode, S3D tries to set the bed temperature before the script runs the heated bed line...I just cut and paste the S3D lines now below the start up script lines and poof, Octopi runs the S3D gcode.

With the upgrades and Simplify3D it's AMAZING the difference in the prints.

Any other Simple Metal users interested in the 32-bit G2 board, I can highly recommend it. Faster and better prints, totally worth the experimenting time and code cut and pasting.....

Hopefully, Printrbot and Simplify3D will get to talking to each other directly.....sent a bunch of emails and messages to Printrbot about building a firmware that has the upgrades included to remove the need for the start up script lines.....

Here's hoping......

chadwalber
Posts: 2
Joined: Wed Nov 29, 2017 11:37 am

Re: Printrbot G2 board upgraded Simple Metal

Wed Nov 29, 2017 11:38 am

I just ordered my G2 board last week. I'm totally pumped for it.

Were there any hurdles installing it? Can you post photos of yours?

whiteb68
Posts: 1
Joined: Sat Apr 18, 2015 7:35 pm

Re: Printrbot G2 board upgraded Simple Metal

Sat Dec 16, 2017 10:43 pm

can you post your start script, I can get the cura to work, just not S3D. tried sending the S3D gcode over octopi and it just times out.

clownfish
Posts: 1
Joined: Thu Aug 18, 2016 8:22 pm

Re: Printrbot G2 board upgraded Simple Metal

Sun Jan 21, 2018 9:40 am

I am in the process of upgrading my original Printrbot Simple Metal to a G2 board. I am able to connect to the printer via OctoPrint but not using S3D. it keep failing on the connection setting. Any setting suggestions for this?

UABMaddog
Posts: 2
Joined: Wed Oct 25, 2017 5:16 pm

Re: Printrbot G2 board upgraded Simple Metal

Fri Feb 15, 2019 12:55 am

Anybody still using their Simple Metal with a G2 board? I've had it on the back burner for almost a year, but thought I'd dust it off and see if I can get this bad boy running again......

chadwalber
Posts: 2
Joined: Wed Nov 29, 2017 11:37 am

Re: Printrbot G2 board upgraded Simple Metal

Mon Feb 18, 2019 10:16 am

UABMaddog wrote:
Fri Feb 15, 2019 12:55 am
Anybody still using their Simple Metal with a G2 board? I've had it on the back burner for almost a year, but thought I'd dust it off and see if I can get this bad boy running again......
I'm trying to. Almost everything works with the exception of the following:

Z Offset
Automatic Bed Leveling

I've tried a bunch of different start gcode/boot settings to try to get these to work. At this point I set them both manually.

Return to “Troubleshooting and Bug Reports”