slaughter2k
Posts: 9
Joined: Tue Sep 05, 2017 3:57 pm

Issue with single extrusion fill :(

Mon Jan 08, 2018 3:25 am

Hi guys... I do have an issue with single extrusion fill.
As everything else is fine (no under or over extrusion on any surfaces) and even single extrusion walls are looking good (at least on first subjective look):
--> I dont get the single extrusion fill working. It is always severe underextruded. Is it possible that I checked any option that might prevent a proper single extrusion fill??
Attached a picture (left: process, right: outcome)
single extrusion infil issue.jpg
My single extrusion setting
general settings.JPG

rrdavis
Posts: 421
Joined: Sat Dec 09, 2017 4:52 am

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 4:01 am

Maybe your extruder is having trouble extruding that much plastic (slipping, pressure build-up, etc). Try reducing all of the speeds by 50% (to do that, just set the default printing speed to half of what it is now). That should give your extruder more time to extrude the thicker lines.

slaughter2k
Posts: 9
Joined: Tue Sep 05, 2017 3:57 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 4:57 am

hm, good idea, but already tried that.
In general the extruder is running really flawless. I can extrude a lot more plastic than this. Current speed setting is 40mm/s. If I screw up the extrusion rate I do not have any issue to fully overextrude everything :) --> so a mechanical restriction of the extruder itself should be unlikely

arhi
Posts: 453
Joined: Thu Oct 06, 2016 5:13 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 9:48 am

50-200% can be too high range for many printers, try to limit range for start 80-120%
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

arhi
Posts: 453
Joined: Thu Oct 06, 2016 5:13 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 9:50 am

also my exp with s3d and single extrusion - you need to have your printer calibrated so that extrusion modifier is 1.00 (so modify either E steps per mm on printer or filament thickness in other/filament properties.. but keep extrusion modifier 1.00)
gcodestat integrates with Simplify3D and allow you to
Calculate print time accurately (acceleration, max speed, junction deviation all taken into consideration)
Embed M117 codes into G-Code
Upload your G-Code directly to Octoprint
open source and unlicence

slaughter2k
Posts: 9
Joined: Tue Sep 05, 2017 3:57 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 10:10 am

Might it be possible that my problem is related to my printer firmware? So...does single extrusion use any "exotic" commands?
I do have a Repetier firmware with a RADDS board on an arduino due
(just thinking in all directions currently :( )

blackbird2016
Posts: 134
Joined: Wed Aug 02, 2017 1:24 am

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 10:25 am

slaughter2k wrote:Might it be possible that my problem is related to my printer firmware? So...does single extrusion use any "exotic" commands?
I do have a Repetier firmware with a RADDS board on an arduino due
(just thinking in all directions currently :( )
As far as i know it does the infills by virtually changeing the nozzle diameter and with it the extrusion width.
I shortly examined a gcode and saw that for the single extrusions there are "tool-switches" from one to an other with different diameters...

slaughter2k
Posts: 9
Joined: Tue Sep 05, 2017 3:57 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 11:11 am

BANG --> I will check that directly when arriving home.
My problem: I am printing with a Y-piece and am switching tools with a tool change script. Maybe this screws up the single extrusion feature.
If this is the case I do hopefully find a workaround...

slaughter2k
Posts: 9
Joined: Tue Sep 05, 2017 3:57 pm

Re: Issue with single extrusion fill :(

Mon Jan 08, 2018 2:39 pm

ok...just started a simple geometry. It's working fine with single extrusion which is smaller than standard width (see pictures)
--> I try to get out where the difference to my "real" model is. It seems that he tries to realize a single extrude which is bigger than one standard width
single extrusion success.jpg
single extrusion success_gcode.jpg
single extrusion success_gcode.jpg (43.78 KiB) Viewed 3378 times

rrdavis
Posts: 421
Joined: Sat Dec 09, 2017 4:52 am

Re: Issue with single extrusion fill :(

Sat Jan 13, 2018 2:54 am

blackbird2016 wrote:I shortly examined a gcode and saw that for the single extrusions there are "tool-switches" from one to an other with different diameters...
It isn't an actual tool change command. It just changes the E-values for how much plastic will be extruded. So even if you are using a custom tool change script, this won't affect you.

Return to “Troubleshooting and Bug Reports”