User avatar
SteveIsHeer
Posts: 48
Joined: Thu Sep 24, 2015 5:45 pm

Live preview tracking not working correctly

Thu Feb 15, 2018 3:29 pm

I have noticed that since installing 4.0.1, the live tracking has issues. If you move the Max layer slider to check how many layers away you are to a specific spot higher up in the model then click the Live preview tracking box to get back to the live display, the layer displayed is always between 5 and 12 layers behind the actual layer currently being printed as seen on the LCD display on the printer. Also if i have the toohead option check marked, the tool head position in the live view, it only shows an update of its position every few layers.

Also wondering why S3D is sending all the "play a tune at the end of print" commands to the controller at the end of a print when I am using Smoothieware firmware, not makerbot AND that option is not selected in the firmware settings. This causes gcodes to still be sent to the printer well after the print is finished and the head has returned to the home position. I had to research the codes on the screen to determine they were the play a tune codes.

I am running:
USB connected Delta with an Azteeg x5 mini v3 controller
Windows 7 Ultimate 64bit with:
32GB RAM
i7 Extreme CPU
nVidia GTX580

EDIT: So this is weird.... I posted the above comment at the beginning of a print and noticed at that time the live preview was lagging 12 layers below what the LCD screen said and now that I am 71% through the print, S3D says it's currently printing layer 914 but the LCD is reporting it's currently on layer 892 and looking at the preview screen definitely shows the progress to be farther along than the actual print is on the printer. This has to be a bug in the software for it to report future instead of live stats.
It show's to go you how feelish you fool when your tang is all tungled up and you bart stalking tackwards!

Return to “Troubleshooting and Bug Reports”