JD95
Posts: 34
Joined: Sun Sep 01, 2013 12:11 pm

Gaps between perimeters and infill visible in g code

Sat Sep 30, 2017 2:11 pm

In a part I was making today, I found areas where material wasn't being placed, leaving unwanted one-bead gaps between surface infill and perimeters, where interior infill wasn't being placed like it should have been, or better yet, the "top" layer extended to the perimeter.
25mm cubic bucket.gcode
(158.94 KiB) Downloaded 182 times
Attachments
Screenshot 2017-09-30 14.02.26.PNG
25mm cubic bucket test.factory
(5.35 KiB) Downloaded 128 times
Last edited by JD95 on Sat Sep 30, 2017 2:31 pm, edited 1 time in total.

JD95
Posts: 34
Joined: Sun Sep 01, 2013 12:11 pm

Re: Gaps between perimeters and infill visible in g code

Sat Sep 30, 2017 2:13 pm

Separate STL in case it's needed. See above post for the factory file.
Attachments
25mm cubic bucket.stl
(15.61 KiB) Downloaded 137 times

User avatar
dkightley
Posts: 2270
Joined: Tue Mar 10, 2015 4:09 pm

Re: Gaps between perimeters and infill visible in g code

Sat Sep 30, 2017 4:05 pm

Set your perimeter/shells to 4.....or change infill to 100%

Your "gap" is the 50% infill that is not being filled because there's only one filament with available.
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

JD95
Posts: 34
Joined: Sun Sep 01, 2013 12:11 pm

Re: Gaps between perimeters and infill visible in g code

Sat Sep 30, 2017 4:22 pm

It does the exact same thing at 0% (oops duh on me), 10%, 30% and 100% infill, and probably everything in between.

I can add perimeters but I think it's a workaround. It's a situation that I would appreciate it if the slicer can avoid doing in the first place. It seems to be a bug that pops up only when the remaining gap for interior infill is one bead width wide or narrower.

Return to “Troubleshooting and Bug Reports”