Posts: 220
Joined: Wed Jul 19, 2017 9:37 am

Mysterious Voids: Solved!

I'm posting this in the hopes that it saves somebody lots of hair pulling when this happens.

I had fine tuned my settings on a small model after switching to a new spool of eSun PLA+, which has been my standard filament for years. Everything looked great, and I tried printing something bigger & more intricate, with lots of internal features. The "seam" where the outer perimeters connect had a region filled with tiny voids at the starting area:
Voids w No Forced Retract 1.jpg
I guessed this was due to a retraction problem, and I spent quite a bit of time experimenting with different amounts of retraction and extra restart distance, but nothing I did seemed to make any difference.

I tried printing another model, and had the same issues, but more intermittently. I could see layers where the retraction adjustments seemed to be working, but the layers with voids were still unaffected. I looked very closely in Preview, and discovered that the void were occurring when there was NOT a retraction before it started the next outer perimeter pass. After looking at my settings, I found that the process I was using had "Force retraction between layers" unchecked. I'm not quite sure why it was skipping the retractions on only some layers, but as soon as I checked that box, the voids went away (top is before, bottom is after):
Voids w No Forced Retract 2.jpg
My best guess is that the voids were the result of losing/oozing filament from the nozzle as it traversed from some distance away. When it started the next pass, the nozzle was initially starved for filament, and the voids resulted. When it used retraction, the filament wasn't leaking significantly, and the extra restart distance compensated for that anyway. When it got to the starting point, it re-primed the nozzle, and all was well.

Return to “Troubleshooting and Bug Reports”