Posts: 7
Joined: Sun Jan 01, 2017 10:32 pm

profiles - singles vs dual wonky behavior

tried reading various threads but i did not see one that matched my situation completely.

i have...
S3D 4.1.2
new ramps 1.4 @ 24v
bt ftf35-e3 v3 screen
dual z axis
2 extruders - new chimera dual in/out
new heat bed 300x300
using new 4498 drivers for all nema17 motors - machine sings beautifully
i have new 300x300 glass bed
all on 2020 frame
i've spent the past week calibrating and tweaking everything

i have gone through and got the profiles for single extrusions pretty dead on for each single print. looks awesome

using the dual print frog. used on older printer several times
when i setup using Tools> Dual Extrusion, i matched the setting for each single setup to the same head in the dual profile.

i cannot get any print to turn out using dual.
i end up having to adjust extrusion rates, retractions, z probe heights lower and others just to get it to stick somewhat.

i can get the first layer to stick but then as time passes it gets thinner, almost non existing. i adjusted flow rate up as needed. 2nd layer is like a river and then adjust flow back down.
it is back and forth with flow rates and i have calibrated extruders because they work with single prints

i use bilinear 5x5 probes
i have ...
m420 s1 z10
g29 v4 t0 - to see grid
the leveling does not seem to adjust at all either between layers.
after level, before print - i marked z motor coupler with marker to watch how it adjust, it stayed on the same mark throughout 1st layer except for raising for next squirt.
i then tried with m420 s1 z0 without difference.

can someone help as why the dual profile is being so hard to work with and why auto-level seems not to work as needed.

i have reflashed marlin several times
i cleared eeprom before new flash
i even bought new mega in case it was the problem
Posts: 1025
Joined: Wed Jun 20, 2018 12:45 pm

Re: profiles - singles vs dual wonky behavior

From the Marlin docs you need to have a bed mesh loaded into EEPROM before m420 can be utilized at all. So I'd first check to make sure you have configured that correctly.

Also the documentation does not list this as a requirement but I'd assume that you need to include a T0 or T1 prior to running the leveling. That should associate the leveling probes with the selected toolhead. Then any associated toolhead offsets can appropriately be applied.
"A bird does not sing because it has an answer. It sings because it has a song."

Return to “Troubleshooting and Bug Reports”