JonasBaleine
Posts: 3
Joined: Thu Jul 06, 2023 7:32 am

Small Top/Bottom Infill along chamfer perimeter

Hi,

Is there a way to get rid of the small top/bottom layer infill squiggles that run along the perimeter for chamfers, as shown in the attached picture?
Screenshot 2023-07-06 074203.png
I feel like I tried every setting already but, apart from reducing bottom and top layers, nothing seems to work.

I am using v5.1.1. I've attached my profile and the generated gcode as well.
C3PO 5e.fff
(43.8 KiB) Downloaded 104 times
Walls_-_Door_BottomRight_Front.gcode
(2.7 MiB) Downloaded 109 times
Thanks for your help!
S3D-Jason
Posts: 1446
Joined: Sun May 31, 2015 6:01 am

Re: Small Top/Bottom Infill along chamfer perimeter

That green fill is typically added if your model has overhangs that require extra reinforcement to maintain the number of top and bottom solid layers that you specified.

You could try lowering the number of top and bottom solid layers to decrease the amount of extra green fill that is required. If you find you want different settings for different regions of the model, you could use the Variable Settings Wizard to only make this change in a specific location.
JonasBaleine
Posts: 3
Joined: Thu Jul 06, 2023 7:32 am

Re: Small Top/Bottom Infill along chamfer perimeter

Thank you for your reply.
Like I mentioned, I tried lowering the number of top/bottom layers and it does work, but does not produce an acceptable part.
I also tried the Variable Setting Wizard, but it is quite tedious for complicated parts that require several processes.
I was hoping there was a setting somewhere to define the overhang that requires this extra reinforcement or to simply turn it off.
nerys
Posts: 257
Joined: Tue Mar 29, 2016 8:47 pm

Re: Small Top/Bottom Infill along chamfer perimeter

S3D-Jason wrote: Thu Jul 06, 2023 11:33 am That green fill is typically added if your model has overhangs that require extra reinforcement to maintain the number of top and bottom solid layers that you specified.

You could try lowering the number of top and bottom solid layers to decrease the amount of extra green fill that is required. If you find you want different settings for different regions of the model, you could use the Variable Settings Wizard to only make this change in a specific location.
Exactly. the setting is broken! and there is NO WAY to remove that except to turn off top or bottom layers. (well it lets you have 1 sometimes)

3 top layers? it adds those throughout the whole damned model. it does not usually break the model but can add a LOT of time to the print time.

the only solution is to meticulously create PROCESSES to carve out the sections where you "WANT" top and bottom layers so the rest can have top and bottom layers turned off entirely to avoid wasting hours of time printing those dumb things. thankfully it only does this nuisance stuff in areas with chamfers/bevels/arcs.
parallyze
Posts: 353
Joined: Fri Jun 05, 2015 4:18 am

Re: Small Top/Bottom Infill along chamfer perimeter

JonasBaleine wrote: Thu Jul 06, 2023 12:21 pm I was hoping there was a setting somewhere to define the overhang that requires this extra reinforcement or to simply turn it off.
Didn't update to v5, but judging by the answer given by S3D-Jason this still can't simply be turned off? Hmm... :|
nerys wrote: ... and there is NO WAY to remove that except to turn off top or bottom layers. (well it lets you have 1 sometimes)

the only solution is to meticulously create PROCESSES to carve out the sections where you "WANT" top and bottom layers so the rest can have top and bottom layers turned off entirely to avoid wasting hours of time printing those dumb things. thankfully it only does this nuisance stuff in areas with chamfers/bevels/arcs.
Actually there is a way to adjust this. It's based on the overlap of the perimeters, so you can try to tweak the same settings
you'd tweak for external overhangs: Extrusion Width and Layer Height.

0.20mm layer height, 0.40mm extrusion width:
020-040.JPG
zigzag support at 30° and 45°


0.20mm layer height, 0.48mm extrusion width (same as auto using a 0.40mm nozzle):
020-048.JPG
zigzag support at 45°


0.12mm layer height, 0.50mm extrusion width:
012-050.JPG
no zigzag support up to 45°
nerys
Posts: 257
Joined: Tue Mar 29, 2016 8:47 pm

Re: Small Top/Bottom Infill along chamfer perimeter

thank you for that. alas I would not call that adjusting anything. I would call that working "around" a problem at a larger time penalty than "dealing" with the problem.

IE going from 0.25 or 0.3mm layer height down to .12 would almost triple print time. 3 times the layers 3 times the time.

we need a way to either ADJUST the angle at which it creates them or simply having the ability to turn them off.

Having a similar problem with the damned separate fill for different speeds issue. if they want to have such a dumb setting then THEY NEED to default all profiles to all speeds at 100% for fill so it only turns on that stuff when we want it too.

Return to “Troubleshooting and Bug Reports”