invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

[SOLVED] failed to create structure for project file: savedstate.factory

I am using V. 5.1.2 and just started having the problem where when i open S3D, the previous profile is not pre-loaded (restore workspace on startup is checked). Whenever i close S3D i get the error "Failed to create structure for project file: savedstate.factory".
Also when i select a gcode file to review after slicing, S3D opens, but the gcode file does not show up in the preview window any longer.
invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

Re: failed to create structure for project file: savedstate.factory

After posting this, i began having problems that S3D would load, but would not load the previous saved state. I would open the printer FFF file and go to slice a part and it would just hang at the slicing portion. you couldn't cancel it either. the only way you could get it out of this point was to close the program. I unchecked the "restore workspace on startup" option and the same thing would happen. no FFF would load and upon slicing a file, it would hang up. I un-installed and re-installed 5.1.2 and i could now slice items, but the same error as the OP pops up. Oddly enough, until yesterday, i never had problems with it reloading the workspace.
S3D-Jason
Posts: 1446
Joined: Sun May 31, 2015 6:01 am

Re: failed to create structure for project file: savedstate.factory

Sounds like that savedState file might have been corrupted. You can try removing that file by following the instructions on this page:
https://www.simplify3d.com/resources/faq/#quest-6350
invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

Re: failed to create structure for project file: savedstate.factory

S3D-Jason wrote: Tue Sep 12, 2023 10:51 am Sounds like that savedState file might have been corrupted. You can try removing that file by following the instructions on this page:
https://www.simplify3d.com/resources/faq/#quest-6350

Neither one of those options made any difference.

I have also uninstalled and reinstalled S3D and the problem still persists.
S3D-Jason
Posts: 1446
Joined: Sun May 31, 2015 6:01 am

Re: failed to create structure for project file: savedstate.factory

Did you follow the full set of instructions at the link above? That should completely remove all settings and files used by the software. At that point, it would be as if you're installing on a completely new computer. For example, it should ask you for your login information at startup.

Assuming you did all that, you shouldn't receive this error when you start the software, since there's no savedState file to begin with.
invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

Re: failed to create structure for project file: savedstate.factory

S3D-Jason wrote: Fri Sep 15, 2023 1:59 pm Did you follow the full set of instructions at the link above? That should completely remove all settings and files used by the software. At that point, it would be as if you're installing on a completely new computer. For example, it should ask you for your login information at startup.

Assuming you did all that, you shouldn't receive this error when you start the software, since there's no savedState file to begin with.
I did, twice. same problem
S3D-Jason
Posts: 1446
Joined: Sun May 31, 2015 6:01 am

Re: failed to create structure for project file: savedstate.factory

When you follow the steps above, do you find a savedState.factory file in the folder mentioned in that link for you to delete? If not, it's possible you're not deleting the correct folder (perhaps there are multiple user accounts on this computer?)

After you follow the settings in the link above, do you see the login dialog the next time you launch S3D? If not, that also suggests you're not deleting the correct files and settings.
invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

Re: failed to create structure for project file: savedstate.factory

S3D-Jason wrote: Mon Sep 18, 2023 7:45 am When you follow the steps above, do you find a savedState.factory file in the folder mentioned in that link for you to delete? If not, it's possible you're not deleting the correct folder (perhaps there are multiple user accounts on this computer?)

After you follow the settings in the link above, do you see the login dialog the next time you launch S3D? If not, that also suggests you're not deleting the correct files and settings.

Yes the savedstate file was in the folder i deleted. It did require me to login after deleting that folder.
S3D-Jason
Posts: 1446
Joined: Sun May 31, 2015 6:01 am

Re: failed to create structure for project file: savedstate.factory

Ok, so you're saying that after following the instructions I posted, you DO see a change in the behavior of the software and it opens successfully? After you enter your login information are you able to use the software as normal?

When do you see the error message in the future? Does it require you to close and reopen the software or logout of the current user account?
invertmast
Posts: 19
Joined: Tue Sep 16, 2014 4:41 pm

Re: failed to create structure for project file: savedstate.factory

S3D-Jason wrote: Wed Sep 20, 2023 11:15 am Ok, so you're saying that after following the instructions I posted, you DO see a change in the behavior of the software and it opens successfully? After you enter your login information are you able to use the software as normal?

When do you see the error message in the future? Does it require you to close and reopen the software or logout of the current user account?
No.


I followed your instructions listed. I tried both options individually, concurrently and with uninstalling the software.

IE.

Tried resetting the software back to factory- no change
I removed the registry entries- no change
Reset the settings back to factory AND removed registry entries- no change
Removed the registry entries and uninstalled/reinstalled- no change


Each time after doing one of the above, i had to log back into the software.


Currently the software will open (with no saved process or model from the previous use) and no errors pop up.

Upon closing the software the “failed to create structure for project file: savedState.factory” still pops up every single time.

Return to “Troubleshooting and Bug Reports”