DaveTea
Posts: 8
Joined: Wed Dec 21, 2022 12:09 am

Linux version issues

Anyone that reads any of these forums can see that S3D has never really had a handle on their Linux version for some reason. Even way back it was always some hoop you had to jump through here and there to get it to run but it was still sold as commercial software with Linux support.

And today its the same.

I wont name the issues here but look around and they are easy to find. It works great unless you are crazy enough to think that you shouldn't run software like this as root. But about 36 hours ago I put in a support request for my paid copy of S3D no longer running as it could not 'activate' and I needed to run it for an urgent project.

Crickets from S3D.

I worked out the issue and its hilarious. So if anyone running Linux wants to know the 'fix' hit me up.
S3D-Jason
Posts: 1340
Joined: Sun May 31, 2015 6:01 am

Re: Linux version issues

It sounds like you may have sent in your support request over the weekend, so hopefully the team has responded by now. They usually respond to everyone within 1-2 days. If you haven't gotten an answer, feel free to PM me your email address and I can check with the team.

I should also mention that we actually have several computers in our office that use Linux as the daily driver OS, and we haven't encountered any of the issues you're describing. I've also setup several completely fresh Linux OS installs in the last 2 months where S3D installed perfectly and ran as expected, no root required. If you're having persistent issues, it's very possible it's something unique about your setup that we haven't encountered here. It would help if you posted exact details about your environment and what specific problems you are having.

Return to “Troubleshooting and Bug Reports”