shauncro
Posts: 4
Joined: Sun Jul 02, 2023 2:40 am

Change number format to decimal place instead of comma

Evening all,

A few months back I moved over to Linux as my daily driver on my personal laptop, where I have S3D installed. But I have been unable to figure out where S3D is getting the number format from for the settings menu. All my settings in Ubuntu are set to South Africa, and when I check the language and region it shows my numbers correctly
Screenshot from 2024-04-08 18-14-56.png
But when I open up S3D, the settings and pertaining numbers don't adopt this format
Screenshot from 2024-04-08 18-25-38.png
Not sure what I'm missing, but I forget this is the issue often enough to get irritated, and have tried searching the forums and haven't come across anything to guide me where to change this setting in Linux.

Ubuntu version is 22.04.4LTS with the latest updates
64bit installation
Gnome version is 42.9
X11 on the windowing system.

Thanks in advance
S3D-Jason
Posts: 1428
Joined: Sun May 31, 2015 6:01 am

Re: Change number format to decimal place instead of comma

I always thought it was based on the system language settings. If you change the language/region back to English, does it switch back to a decimal place?
shauncro
Posts: 4
Joined: Sun Jul 02, 2023 2:40 am

Re: Change number format to decimal place instead of comma

Hey Jason,

On windows it works off the region settings, but no quite sure why it isn't working with the linux version. I have tried a few language and region settings, but nothing seems to help. Later on I'll look at uninstalling the app then re-installing. It could be my install of ubuntu that is the issue, I noticed yesterday evening that all my desktop icons suddenly disappeared, though they are in the desktop folder. So I'm leaning towards that being the issue rather than simplify. Probably only get around to formatting this weekend. But will feedback if it sorts it out or not.
S3D-Jason
Posts: 1428
Joined: Sun May 31, 2015 6:01 am

Re: Change number format to decimal place instead of comma

So you're saying that setting all language and region settings back to English still doesn't change it from a comma to a period? Perhaps you need to select English USA instead of English UK?
shauncro
Posts: 4
Joined: Sun Jul 02, 2023 2:40 am

Re: Change number format to decimal place instead of comma

Hey Jason,

Yes that is correct. I have a fresh install now, running the latest version of Ubuntu LTS and same thing hey, my location is set to English South Africa, and language is set to English US, if that makes a difference. Just finished installing Simplify and location and language were setup during install.

Could it perhaps not be using the number separator opposed to the decimal point?
Attachments
Screenshot from 2024-05-02 19-48-35.png
Screenshot from 2024-05-02 19-47-36.png
Screenshot from 2024-05-02 19-42-56.png
TheBum
Posts: 196
Joined: Fri May 18, 2018 11:13 pm

Re: Change number format to decimal place instead of comma

What happens if you change your location setting to US? It may be based on location and not language.
shauncro
Posts: 4
Joined: Sun Jul 02, 2023 2:40 am

Re: Change number format to decimal place instead of comma

strangely, that worked. And it's still in metric and hasn't changed to imperial. I did try that in 22.04 but that install was a bit messed, so didn't take I guess.

It did how ever reset my profile back to default, luckily that's quick to fix all my settings. Last os crashed earlier and didn't have a chance to export my profiles, but not a train smash.

Now to see if our accounting app will work tomorrow still. It has to have A4 set as the default print size, and US defaults to letter, but I'll find a way around that I'm sure.

Return to “General Discussion and Tips”