mperdue
Posts: 8
Joined: Tue Dec 08, 2015 11:58 pm

Setting Extruder Temp on Duet

Mon Jul 02, 2018 7:39 pm

When I use S3D to slice a part it sends an M104 to set the temperature and an M109 to wait for the extruder to get to that temperature.

This sets the extruder active temperature but it also sets the extruder standby temperature. My standby temperature is already correct so I don't want it changed. Codes M104 and M109 have been deprecated in reprapfirmware and replaced with G10 and M116 respectively. Is there any way to change this so it works correctly with my Duet WiFi based printers?

User avatar
mntbighker
Posts: 33
Joined: Sun Jun 24, 2018 7:33 pm
Location: Silicone Valley

Re: Setting Extruder Temp on Duet

Wed Jul 04, 2018 4:15 pm

+1
Scratch built CoreXY with Duet Maestro
Heavily modified Ender 3 with Duet Maestro
MPCNC work in progress with Duet WiFi

brunofporto
Posts: 33
Joined: Wed Nov 29, 2017 7:36 am

Re: Setting Extruder Temp on Duet

Mon Jul 16, 2018 3:32 pm

T0 ; Selects Tool 0
M140 S[bed0_temperature] ; Start heating bed
M116 H0 ; Waits bed to finish heating (H0 is the bed heater)
M104 S[extruder0_temperature] ; Starts heating the nozzle while...
G28 ; home all axes
G29 S1 ; sets to use mesh Bed leveling
G1 X2 Y0 F10000; Go to wait position (where I ussualy celans the ooze)
M116 P1; Waits for finish the heating of the hotend

I think this solves your doubt :D

After that I do this:

;====================
M98 P/macros/SubMacros/beep.g ; beep to warn me to clean the ooze
G4 P30000 ; Waits 30 secons so I can clean the ooze
;====================
G1 Z0.2 ; Go closer to the bed
G92 E0 ;zero the extruded length
G1 E10 F1000 ; Purges ouside the glass cutting any ooze (my printer specific)
G1 Y60 E9 F1000 ; Purge line 1 (my printer specific)
G1 Y90 E12.5 F1000; purge line 2 (my printer specific)
G92 E0 ;zero the extruded length again

S3D-Jake
Posts: 960
Joined: Wed Jun 20, 2018 12:45 pm

Re: Setting Extruder Temp on Duet

Tue Aug 28, 2018 9:59 am

mperdue wrote:
Mon Jul 02, 2018 7:39 pm
When I use S3D to slice a part it sends an M104 to set the temperature and an M109 to wait for the extruder to get to that temperature.

This sets the extruder active temperature but it also sets the extruder standby temperature. My standby temperature is already correct so I don't want it changed. Codes M104 and M109 have been deprecated in reprapfirmware and replaced with G10 and M116 respectively. Is there any way to change this so it works correctly with my Duet WiFi based printers?
You can update which heating commands get used in your files by changing the firmware configuration. viewtopic.php?t=1944
"A bird does not sing because it has an answer. It sings because it has a song."

Return to “General Discussion and Tips”