RoboDLC
Posts: 79
Joined: Sun Apr 23, 2017 2:30 am

How do I print two dual-color models at a time?

Sun Jan 12, 2020 10:55 am

I have fiddled for over an hour with this and failed.
No matter what models I chose for a given process, when I try to use the dual-color tool, it selects all models. That doesn't work.
I try to start with the dual-model tool and then select models, nope doesn't work either.
Is it just not possible to print two dual-color models at the same time?

How about a manual S3D?

Thanks,
DLC
D. Clark
Robotics and sensors engineer
And lots of other stuff for fun.

User avatar
dkightley
Posts: 2283
Joined: Tue Mar 10, 2015 4:09 pm

Re: How do I print two dual-color models at a time?

Sun Jan 12, 2020 1:09 pm

I don't have a multi-extruder printer....but if I did, I'd read this:
https://www.simplify3d.com/support/arti ... extruders/
Doug Kightley
Volunteer at the National Tramway Museum http://www.tramway.co.uk
Railway modeller and webmaster at http://www.talkingtgauge.net

RoboDLC
Posts: 79
Joined: Sun Apr 23, 2017 2:30 am

Re: How do I print two dual-color models at a time? SOLVED

Sun Jan 12, 2020 4:59 pm

That did help to refresh my memory about processes. When using the dual color tool however, they confuse the issue by grouping dual-color objects in the "models" window, and giving that group a name, and grouping processes in the Process window, and allowing you to assign those names. But, although one is a model group and the other is a process group, they are not allowed the same name. So I guess that a model group and a process group are the same thing? No, they aren't.

You cannot use the the dual-extrusion wizard on two separate models to print at the same time. At least as a "one-shot" define. You do need to use it to sort model parts into their correct colors - for ALL models at the same time.

First, load your models, then:
You need to group and align each model manually, using the edit->group selection, and edit->align selected model groups. In that order.
THEN you need to use your dual-extrusion wizard (checking OFF the group and align checkbox because you already did this manually) and sort your model pieces into the correct colors, which get grouped as Color1 and Color2 processes. If you don't uncheck the "group and align" box, the wizard will combine ALL model parts into one piece. Not what you want.

After you do this, you now have a grouped set of processes. You can customize the "Color1/Color2" into your actual color names so you don't get them confused.

Now, select Color1 process and edit it. In the bottom left corner you have [select models] button. Click on that to make sure that the correct parts are assigned to their correct colors. You can change them around here. This is really weird, because even though both of these processes have both extruders in them, each only uses one of them. I find that strange I would have expected to have to processes ordered by "model", not by extruder used.

Regardless of the incomprehensibility of how the processes are arranged, the proper models are now aligned and will print all at the same time.

You can now arrange your grouped models on your build surface. Click "[prepare to print], in this pop-up you must click [Select All] to get both processes to print. You will now see your color and model groupings.

I have done this with both a Chimera (dual filament/dual nozzle) and a Cyclops (dual filament/single nozzle). They both print great.
When printing with the Chimera, I use an ooze wall and special g-codes on the "tool change" script tab to move the head off the model, drop the temperature on the unused head (set and forget), and bring the temperature up on the active head (set and wait for temperature), the, rest of the g-code handles moving the carriage back to the correct next spot to print.

On the Cyclops I need to use a priming tower to pump out the last filament used and prime for the next filament. I then also use an ooze wall to "wipe" drool off of the head as it comes back to the print. I use a .1mm Z lift so the nozzle is still wiped, but I don't have the nozzle collide with the wall on the way in or out. That makes me nervous.

Because you have to wait for the Chimera head to heat up, the single-nozzle dual-color print head is faster to print with. However the dual nozzle Cyclops makes a cleaner print.

There you go, hopefully the above is clear, I THINK that I wrote it all down.
DLC

*EDIT*
Here are the results, I printed these using a coarse .3mm layer for speed. The Cyclops printed in 2hr 17min, the Chimera in 2hr 47min. The Cyclops was on my slowest printer too. The photo order is: results, Chimera, Cyclops
Attachments
CyclopsChimeraCompare.JPG
ChimeraProcess.JPG
CyclopsProcess.JPG
D. Clark
Robotics and sensors engineer
And lots of other stuff for fun.

Return to “General Discussion and Tips”