nophead
Posts: 7
Joined: Sat May 16, 2020 8:09 am

solidlayers when infill is 100%

When I slice this object that has holes in the bottom it creates 4 layers of infill to cover them. This makes sense when the infill is sparse but I am using 100% infill so it should just be one single layer of 100% fill.

Image
Last edited by nophead on Tue Dec 19, 2023 1:48 pm, edited 3 times in total.
S3D-Jason
Posts: 1452
Joined: Sun May 31, 2015 6:01 am

Re: solidlayers when infill is 100%

The internal infill and the outer solid layers can each have very different settings. You might be using different speeds, extrusion rates, widths, etc. That is why they are typically printed separately. For example, I bet if you change the preview coloring to movement speed, you will see those 2 regions use a different printing speed.

If you want to just print everything together with 100% infill, an easy trick is to go to Edit Process Settings > Infill tab, and enable the "Add Solid Diaphragms" option with 1 layer and 0 spacing. Now the entire part will be a single solid region.
nophead
Posts: 7
Joined: Sat May 16, 2020 8:09 am

Re: solidlayers when infill is 100%

They are all the same speed because I try to print at constant flow rate for best quality.

Image


The Add Solid Diaphragms trick works though, thanks.
gearsawe
Posts: 233
Joined: Sun Sep 10, 2017 11:06 pm

Re: solidlayers when infill is 100%

so when I print 100% infill I set top and bottom layers to zero.

Return to “Troubleshooting and Bug Reports”