dennisharrison
Posts: 1
Joined: Tue Nov 07, 2017 5:02 pm

Flash Forge Creator Pro - Start Gcode - Left Extruder

Tue Nov 07, 2017 5:43 pm

Hope this helps, I've been very happy with it. Fixes needing to set gcode offset for Octoprint too.

Modified from Dr. Lex's for Slic3r Prusa Edition - he's got a very good writeup on why here: https://www.dr-lex.be/info-stuff/print3 ... #code_note

T0; start with the right extruder. We’ll switch to T1 after having moved the print head to provide enough space for the nozzle offset.
M73 P0 ; enable build progress
M104 S140 T1; preheat nozzle to 140 degrees, this should not cause oozing
M140 S[bed0_temperature] T0
M127; disable fan
G21; set units to mm
M320; acceleration enabled for all commands that follow
G162 X Y F8400 ; home XY maximum
G161 Z F1500 ; home Z minimum
G92 X0 Y0 Z0 E0 B0; set (rough) reference point (also set E and B to make GPX happy)
G1 Z5 F1500; move the bed down again
G4 P0; Wait for command to finish
G161 Z F100; accurately home Z axis minimum
G92 Z0; set accurate Z reference point
M132 X Y Z A B; Recall stored home offsets
G90; set positioning to absolute
G1 Z20 F1500; move Z to waiting height
G1 X135 Y75 F1500; do a slow small move because the first move is likely not accelerated
G1 X70 Y-82 F8400; move to waiting position (front right corner of print bed), also makes room for the tool change
M18 E; disable extruder steppers while heating
M126 S[fan_speed_pwm]
M134 T0 ; stabilize bed temperature
M104 S[extruder1_temperature] T1
M133 T1 ; stabilize left extruder temperature
M17; re-enable all steppers
G4 P0; flush pipeline
T1; switch to the left extruder
G4 P0; flush pipeline
G92 E0; set extrusion zero reference
G1 Z0 F1000
G1 X70 Y-73 F4000; chop off any ooze on the front of the bed
G1 Z[next_position_z] F1500; move to first layer height
G1 X-121 Y-73 E24 F2000; extrude a line of filament across the front edge of the bed
; Note how we extrude a little beyond the bed, this produces a tiny loop that allows to manually remove the extruded strip.
G1 Z0 F1500; lower nozzle height to 0
G1 X-108 F4000; chop nozzle on edge of bed
G1 Z[next_position_z] F1500; back to first layer height
G1 X-100 F4000; wipe across the extruded line (X direction)
G1 X-90 Y-78 F6000; Move back for an additional wipe (Y direction)
G92 E-0.6; should set reference to 0 here, but deliberately cause a little over-extrusion to combat typical extruder lag at the start of the actual print.
G1 F8400; in case Slic3r would not override this, ensure fast travel to first print move
M73 P1 ;@body (notify GPX body has started)

User avatar
jrpmedia
Posts: 34
Joined: Sun Nov 02, 2014 12:36 pm
Location: UK
Contact: Website

Re: Flash Forge Creator Pro - Start Gcode - Left Extruder

Fri Aug 16, 2019 6:52 am

If I change all the T1 GCODE Values to a T0 it still wants to use the LEFT extruder all the time ...
... and I want it to only use the RIGHT EXTRUDER of T0

What am I missing :-(

FlashForge Creator Pro 2017
CURA 4.2.1
Mac OSX 10.14.6
IDM Imagineering
Professional Equipment for SuperHEROs.
https://www.idmimagineering.co.uk

Return to “General Discussion and Tips”