chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Qidi X-Pro Amazon review with potentially useful settings...

Thu Dec 14, 2017 9:17 am

Hi.

New member here. I just bought the new Qidi X-Pro and am trying to use S3D with it. A reviewer on Amazon posted settings he said that he got to work:

https://www.amazon.com/gp/customer-revi ... B076BLQWHY

I followed the instructions and when I put the gcode file into the machine, the wiping operation happens and then no material feeds after that. I kept the PLA nozzle temperatures at 190C and the platform at 60C because those have been working in the files generated by the Qidi software. I tried the entire process twice with the same results.

Any idea what I'm missing?

I sent the guy's review to the S3D tech support people, hoping it will get an official profile from them faster.

Here is what he suggested:

-----
If you want to use S3D, here is a short how-to:

1. Select "other" from help->configuration assistant.
2. Set up dual extruders, Right is T0 and Left is T1. Set the extrusion multiplier is 1.11 (I did the math to match QIDI file).
3. Set primary layer height to 0.18 mm.
4. ABS temp settings: 230C for extruder, 115C for platform (make sure you choose T0/T1 to match the proper extruder)
5. PLA temp settings: 220C for extruder, 65C for platform.
6. Under the gcode tab, check the following: 1) 5D firmware, 2) Allow zeroing of extrusion distances, 3) Firmware support sticky parameters, 4) build volume: 230x150x150, all offsets are 0, and select RepRap for the firmware.
7. Set the left extruder tool offset (index "Tool 1") to X:34, Y:0.
8. Startup Script:

G28 X0 Y0
G0 X-1000 Y-1000 F1800
G28 Z0
G1 X0 Y0 Z50 F3600
G1 X0 Y0 F3600
G92 E0
G92 A0 B0
G0 X0 Y4 Z0.3 F3600
G1 X230 A18 F2400
G1 X230 Y5 F2400
G1 X35 F2400
G92 A0 B0

9. Shutdown Script:

M107
M104 S0 ; cool left extruder
M104 S0 T1 ; cool right extruder
M140 S0 ; cool build plate
G92 E0
G1 Z150 F900
G28 X0 Y0
M84
M104 S0

I left all other settings default and have had great results.
-----

Once a profile is developed by S3D, it would be nice to be able to use the machine's Wifi gcode file transfer feature.

Thanks!

Chase

rseal
Posts: 9
Joined: Sat Dec 16, 2017 3:21 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Sat Dec 16, 2017 3:33 pm

I'm the guy who posted the review on Amazon. I've attached an fff file that should get you going. Also, another person was asking about wifi access. To connect your printer to your network, create a text file containing : M9003 '"SSID","PASSWORD"' , where SSID/PASSWORD are used to connect to your network. I can print wifi via QidiPrint, but still haven't had any luck with S3D.

Good luck,

Ryan
Attachments
Qidi x-pro-abs.fff
Qidi x-pro settings
(14.79 KiB) Downloaded 409 times

chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Sun Dec 17, 2017 8:34 am

Wow!

Thank you so much for replying to my post. I was hoping that would happen.

I have the settings loaded and have a test gcode file all set to run after my current print is done.

I still don't understand why you have the PLA extruder temps set so high. I turned them down to what I know works (190C).

I would send you a PM, but I'm too new here for the forum to allow that.

Chase

chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Sun Dec 17, 2017 9:57 am

Update:

Same story as before. It does everything except extruded filament onto the platform (at 190 degrees). There is a VERY thin smearing of filament, but it isn't really extending. I tried a gcode file from the Qidi software and it worked without problems at 190 degrees.

I'm puzzled.

rseal
Posts: 9
Joined: Sat Dec 16, 2017 3:21 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Mon Dec 18, 2017 12:48 pm

The 190C is probably fine. I played around with anything from 195-220 and didn't see a huge difference, but these were not challenging prints.

I did go into the qidi gcode file and calculated the amount of material extruded per distance, and compared with the s3d file, they were within 10% of each other (probably closer if I had matched the widths, missed that). The S3D file zeros out the extruder value at virtually every step (which is more intuitive), so don't get thrown off by that if you start digging.

Take a look at the LCD when printing and make sure that the correct extruder is at the correct temperature. It almost sounds like you're warming up both extruders and then shutting the one you want to use down when the print starts. I did initially have a few issues with this using both qidi and s3d, just a bit of confusion since you can potentially use both extruders. Looking at the commands in the gcode sorted this out pretty quickly. You can also hand-edit the M104 command if you to quickly test which extruder is which.

Ryan

rseal
Posts: 9
Joined: Sat Dec 16, 2017 3:21 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Tue Dec 19, 2017 9:49 am

I've attached a factory file and test print set up for ABS on the right extruder.
Attachments
s3d.factory
(1.84 MiB) Downloaded 252 times
frog_s3d_qidi_xpro_abs_right_ext.gcode
(2.32 MiB) Downloaded 232 times

chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Tue Dec 19, 2017 9:58 am

Thanks! Will give it a shot.

chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Tue Dec 19, 2017 12:39 pm

OK. The gcode file works. You have the bed temp set way up to 100C, but it works.

I was playing with the factory file for a few minutes at lunch and I guess I don't know what I'm doing. A local buddy can help me, though.

I was trying to change from ABS to PLA at the upper left and set a left extruder but you have the left extruder temp set to zero regardless of which I choose. ...unless I'm totally missing something. Do you have everything set for PLA and the profile is just called ABS?

Will keep plugging away at it...

Thanks again!

Chase

rseal
Posts: 9
Joined: Sat Dec 16, 2017 3:21 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Tue Dec 19, 2017 3:57 pm

The settings and gcode I gave you were for ABS: 100C for the bed and something like 225C for the right extruder. My current setup has the left extruder using PLA and the right extruder using ABS. That may be different from your setup.

I had quite a few profiles set up when I started and then s3d crashed and I lost everything. I've since moved to Linux (where I normally live anyway) and have learned to periodically save the FFF and factory files. If I have time tonight I'll work up a PLA profile and send it to you. The last time I used PLA I was printing at 205C with a bed temp of 60C, pretty average I think.

chase
Posts: 11
Joined: Tue Dec 12, 2017 3:44 pm

Re: Qidi X-Pro Amazon review with potentially useful setting

Tue Dec 19, 2017 4:13 pm

Aha! That explains it.

I only work with PLA, so if you could please set one up with a PLA left and PLA right, both with the PLA temperatures, that would be great.

Chase

Return to “Feature Requests”